<!DOCTYPE html> <!--[if lt IE 7]><html class="no-js lt-ie9 lt-ie8 lt-ie7 is_msie"><![endif]--> <!--[if IE 7]><html class="no-js lt-ie9 lt-ie8 is_msie"><![endif]--> <!--[if IE 8]><html class="no-js lt-ie9 is_msie"><![endif]--> <!--[if IE 9]><html class="no-js lt-ie10 is_msie"><![endif]--> <!--[if IE 10]><html class="no-js lt-ie11 is_msie"><![endif]--> <!--[if gt IE 8]><!--><html class="no-js"><!--<![endif]--><head><meta http-equiv="X-UA-Compatible" content="IE=edge"><meta http-equiv="Content-Type" content="text/html; charset=UTF-8"><meta charset="utf-8"><meta name="viewport" content="width=device-width"><title>Are your DSAs really outperforming standard ads? Find out with this ad copy length performance analysis script - Search Engine Land</title><style id="rocket-critical-css">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</style><link rel="preload" href="https://fonts.googleapis.com/css?family=Oswald%3A300%2C400%2C700%7CRoboto%3A300%2C400%2C700&display=swap" as="style" onload="this.onload=null;this.rel='stylesheet'" /><link rel="preload" href="https://searchengineland.com/figz/wp-content/cache/min/1/15687c107e76059dfb406da3f7e2d7ab.css" as="style" onload="this.onload=null;this.rel='stylesheet'" data-minify="1" /><meta property="fb:app_id" content="108479729193136" /><meta property="fb:admins" content="684476602, 1269303818, 679476803, 549118759"/><meta property="twitter:account_id" content="1059801" /><meta name="twitter:card" content="app"><meta name="twitter:site" content="@sengineland"><meta name="twitter:description" content="Search Engine Land is the leading industry source for daily, must-read news and in-depth analysis about search engine technology."><meta name="twitter:app:country" content="US"><meta name="twitter:app:name:iphone" content="Search Engine Land"><meta name="twitter:app:id:iphone" content="1015557452"><meta name="twitter:app:name:ipad" content="Search Engine Land"><meta name="twitter:app:id:ipad" content="1015557452"><meta name="twitter:app:name:googleplay" content="Search Engine Land"><meta name="twitter:app:id:googleplay" content="com.thirddoormedia.searchengineland"><meta name="google-site-verification" content="c9app5XVp8lVmCyt-cHaPGOrTdwfrBbZW6HoZeH7Rnc" /><meta property="fb:page_id" content="7138936668" /><meta name="news_keywords" content=""><meta itemprop="description" content="Here's a script that pulls a report on ad performance based on copy length."><meta itemprop="datePublished" content="2019-07-12" /><meta itemprop="dateModified" content="2019-07-12" /><meta itemprop="image" content="https://searchengineland.com/figz/wp-content/seloads/2019/07/Google-ads-script-2-800x450.jpg" /> <script type="application/ld+json">{
	  "@context" : "http://schema.org",
	  "@type" : "Organization",
	  "name" : "Search Engine Land",
	  "url" : "https://searchengineland.com",
	  "sameAs" : [
	    "http://www.facebook.com/searchengineland",
	    "http://www.twitter.com/sengineland",
	    "https://plus.google.com/+SearchEngineLand",
		"https://www.linkedin.com/company/search-engine-land",
		"http://www.instagram.com/searchengineland",
		"http://www.pinterest.com/sengineland",
		"http://www.searchengineland.tumblr.com"
	  ]
	}</script> <link rel="apple-touch-icon" href="https://searchengineland.com/apple-touch-icon.png"><link rel="shortcut icon" href="https://searchengineland.com/favicon.ico" /><link rel="alternate" type="application/rss+xml" title="Search Engine Land Feed: Get Every Post" href="http://feeds.searchengineland.com/searchengineland" /><link rel="alternate" type="application/rss+xml" title="SearchCap: Daily Recap Of Search News" href="http://feeds.searchengineland.com/searchcap" /><link rel="canonical" href="https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Are your DSAs really outperforming standard ads? Find out with this ad copy length performance analysis script - Search Engine Land" /><meta property="og:description" content="Here&#039;s a script that pulls a report on ad performance based on copy length." /><meta property="og:url" content="https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416" /><meta property="og:site_name" content="Search Engine Land" /><meta property="article:publisher" content="https://www.facebook.com/searchengineland" /><meta property="article:section" content="Channel: SEM" /><meta property="article:published_time" content="2019-07-12T18:27:07+00:00" /><meta property="article:modified_time" content="2019-07-12T18:35:25+00:00" /><meta property="og:updated_time" content="2019-07-12T18:35:25+00:00" /><meta property="og:image" content="https://searchengineland.com/figz/wp-content/seloads/2019/07/Google-ads-script-2.jpg" /><meta property="og:image:secure_url" content="https://searchengineland.com/figz/wp-content/seloads/2019/07/Google-ads-script-2.jpg" /><meta property="og:image:width" content="1478" /><meta property="og:image:height" content="832" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Here&#039;s a script that pulls a report on ad performance based on copy length." /><meta name="twitter:title" content="Are your DSAs really outperforming standard ads? Find out with this ad copy length performance analysis script - Search Engine Land" /><meta name="twitter:site" content="@sengineland" /><meta name="twitter:image" content="https://searchengineland.com/figz/wp-content/seloads/2019/07/Google-ads-script-2.jpg" /><meta name="twitter:creator" content="@dangilbertppc" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://searchengineland.com/#organization","name":"Search Engine Land","url":"https://searchengineland.com/","sameAs":["https://www.facebook.com/searchengineland","https://twitter.com/sengineland"],"logo":{"@type":"ImageObject","@id":"https://searchengineland.com/#logo","url":"https://searchengineland.com/figz/wp-content/seloads/2019/05/SearchEngineLand_logo_1920x1080.png","width":1920,"height":1080,"caption":"Search Engine Land"},"image":{"@id":"https://searchengineland.com/#logo"}},{"@type":"WebSite","@id":"https://searchengineland.com/#website","url":"https://searchengineland.com/","name":"Search Engine Land","publisher":{"@id":"https://searchengineland.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://searchengineland.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416#webpage","url":"https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416","inLanguage":"en-US","name":"Are your DSAs really outperforming standard ads? Find out with this ad copy length performance analysis script - Search Engine Land","isPartOf":{"@id":"https://searchengineland.com/#website"},"image":{"@type":"ImageObject","@id":"https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416#primaryimage","url":"https://searchengineland.com/figz/wp-content/seloads/2019/07/Google-ads-script-2.jpg","width":1478,"height":832},"primaryImageOfPage":{"@id":"https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416#primaryimage"},"datePublished":"2019-07-12T18:27:07+00:00","dateModified":"2019-07-12T18:35:25+00:00"},{"@type":"NewsArticle","@id":"https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416#article","isPartOf":{"@id":"https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416#webpage"},"author":{"@id":"https://searchengineland.com/author/daniel-gilbert#author"},"headline":"Are your DSAs really outperforming standard ads? Find out with this ad copy length performance analysis script","datePublished":"2019-07-12T18:27:07+00:00","dateModified":"2019-07-12T18:35:25+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416#webpage"},"publisher":{"@id":"https://searchengineland.com/#organization"},"image":{"@id":"https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416#primaryimage"},"articleSection":"Channel: SEM,Google: AdWords: AdWords Scripts,Paid Search Column","copyrightYear":"2019","copyrightHolder":{"@id":"https://searchengineland.com#organization"}},{"@type":["Person"],"@id":"https://searchengineland.com/author/daniel-gilbert#author","name":"Daniel Gilbert","image":{"@type":"ImageObject","@id":"https://searchengineland.com/#authorlogo","url":"https://secure.gravatar.com/avatar/e250850de9e0ac31f47c3f0e463b4b1a?s=96&d=mm&r=g","caption":"Daniel Gilbert"},"description":"Daniel Gilbert is the CEO at <a href=\"http://www.brainlabsdigital.com\">Brainlabs</a>, the best paid media agency in the world (self-declared). He has started and invested in a number of big data and technology startups since leaving Google in 2010.","sameAs":["http://uk.linkedin.com/in/danielgilbert1","https://twitter.com/dangilbertppc"]}]}</script> <link rel='dns-prefetch' href='//727-zqe-044.mktoresp.com' /><link rel='dns-prefetch' href='//static.chartbeat.com' /><link rel='dns-prefetch' href='//tpc.googlesyndication.com' /><link rel='dns-prefetch' href='//staticxx.facebook.com' /><link rel='dns-prefetch' href='//googleads.g.doubleclick.net' /><link rel='dns-prefetch' href='//www.google-analytics.com' /><link rel='dns-prefetch' href='//cdn.ampproject.org' /><link rel='dns-prefetch' href='//pagead2.googlesyndication.com' /><link rel='dns-prefetch' href='//secure.quantserve.com' /><link rel='dns-prefetch' href='//d2j3qa5nc37287.cloudfront.net' /><link rel='dns-prefetch' href='//munchkin.marketo.net' /><link rel='dns-prefetch' href='//adservice.google.com' /><link rel='dns-prefetch' href='//apis.google.com' /><link rel='dns-prefetch' href='//www.google.com' /><link rel='dns-prefetch' href='//connect.facebook.net' /><link rel='dns-prefetch' href='//securepubads.g.doubleclick.net' /><style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important}</style><style id='rocket-lazyload-inline-css' type='text/css'>.rll-youtube-player{position:relative;padding-bottom:56.23%;height:0;overflow:hidden;max-width:100%}.rll-youtube-player iframe{position:absolute;top:0;left:0;width:100%;height:100%;z-index:100;background:0 0}.rll-youtube-player img{bottom:0;display:block;left:0;margin:auto;max-width:100%;width:100%;position:absolute;right:0;top:0;border:none;height:auto;cursor:pointer;-webkit-transition:.4s all;-moz-transition:.4s all;transition:.4s all}.rll-youtube-player img:hover{-webkit-filter:brightness(75%)}.rll-youtube-player .play{height:72px;width:72px;left:50%;top:50%;margin-left:-36px;margin-top:-36px;position:absolute;background:url(https://searchengineland.com/figz/wp-content/plugins/wp-rocket/assets/img/youtube.png) no-repeat;cursor:pointer}</style> <script data-minify="1" type='text/javascript' defer="defer" src='https://searchengineland.com/figz/wp-content/cache/min/1/figz/wp-content/themes/searchengineland/js/lib/modernizr.custom-f6d111c1252dd322abe8496b4cc54ac8.js'></script> <script type='text/javascript' defer="defer" src='https://searchengineland.com/figz/wp-content/cache/busting/1/figz/wp-content/themes/searchengineland/js/lib/jquery-1.11.0.min-1.11.0.js'></script> <script type='text/javascript' defer="defer" src='https://searchengineland.com/figz/wp-content/cache/busting/1/figz/wp-content/themes/searchengineland/js/lib/jquery-ui-1.10.3.custom.min-1.10.3.js'></script> <script type='text/javascript' defer="defer" src='https://searchengineland.com/figz/wp-content/cache/busting/1/figz/wp-content/themes/searchengineland/js/lib/jquery.ba-throttle-debounce.min-1.1.js'></script> <script type='text/javascript' defer="defer" src='https://searchengineland.com/figz/wp-content/cache/busting/1/figz/wp-content/themes/searchengineland/js/lib/jquery.countdown.min-2.0.4.js'></script> <link rel='https://api.w.org/' href='https://searchengineland.com/wp-json/' /><link rel='shortlink' href='https://searchengineland.com/?p=319416' /><link rel="amphtml" href="https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416/amp"><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player,[data-lazy-src]{display:none!important}</style></noscript><script>/*! loadCSS rel=preload polyfill. [c]2017 Filament Group, Inc. MIT License */
(function(w){"use strict";if(!w.loadCSS){w.loadCSS=function(){}}
var rp=loadCSS.relpreload={};rp.support=(function(){var ret;try{ret=w.document.createElement("link").relList.supports("preload")}catch(e){ret=!1}
return function(){return ret}})();rp.bindMediaToggle=function(link){var finalMedia=link.media||"all";function enableStylesheet(){link.media=finalMedia}
if(link.addEventListener){link.addEventListener("load",enableStylesheet)}else if(link.attachEvent){link.attachEvent("onload",enableStylesheet)}
setTimeout(function(){link.rel="stylesheet";link.media="only x"});setTimeout(enableStylesheet,3000)};rp.poly=function(){if(rp.support()){return}
var links=w.document.getElementsByTagName("link");for(var i=0;i<links.length;i++){var link=links[i];if(link.rel==="preload"&&link.getAttribute("as")==="style"&&!link.getAttribute("data-loadcss")){link.setAttribute("data-loadcss",!0);rp.bindMediaToggle(link)}}};if(!rp.support()){rp.poly();var run=w.setInterval(rp.poly,500);if(w.addEventListener){w.addEventListener("load",function(){rp.poly();w.clearInterval(run)})}else if(w.attachEvent){w.attachEvent("onload",function(){rp.poly();w.clearInterval(run)})}}
if(typeof exports!=="undefined"){exports.loadCSS=loadCSS}
else{w.loadCSS=loadCSS}}(typeof global!=="undefined"?global:this))</script>  <script type='text/javascript'>var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();</script> <script type='text/javascript'>googletag.cmd.push(function() {
	googletag.defineSlot('/1038259/sel-ciu-1', [730, 77], 'div-gpt-ad-1383602995881-0').addService(googletag.pubads());
	googletag.defineSlot('/1038259/sel-ciu-2', [730, 77], 'div-gpt-ad-1383602995881-1').addService(googletag.pubads());
	googletag.defineSlot('/1038259/sel-ciu-3', [730, 77], 'div-gpt-ad-1383602995881-2').addService(googletag.pubads());
	googletag.defineSlot('/1038259/sel-ciu-4', [730, 77], 'div-gpt-ad-1496720069653-2').addService(googletag.pubads());
    googletag.defineSlot('/1038259/sel-ciu-5', [730, 77], 'div-gpt-ad-1496720069653-3').addService(googletag.pubads());

        googletag.defineSlot('/1038259/SEL-Parallax', [1, 1], 'div-gpt-ad-1550690821057-0').addService(googletag.pubads());
        
googletag.defineSlot('/1038259/ch-sem-leaderboard', [[728, 90], [970, 90], [970, 250]], 'div-gpt-ad-ch-sem-leaderboard').addService(googletag.pubads());
googletag.defineSlot('/1038259/ch-sem-sidebar', [[160, 600], [300, 250], [300, 600]], 'div-gpt-ad-ch-sem-sidebar').addService(googletag.pubads());
googletag.defineSlot('/1038259/ch-sem-lower-sidebar', [[160, 600], [300, 250], [300, 600]], 'div-gpt-ad-ch-sem-lower-sidebar').addService(googletag.pubads());
googletag.defineSlot('/1038259/ch-sem-overlay', [1, 1], 'div-gpt-ad-ch-sem-overlay').addService(googletag.pubads());
googletag.defineSlot('/1038259/ch-sem-articlemodule', [800, 440], 'div-gpt-ad-ch-sem-articlemodule').addService(googletag.pubads());
googletag.defineSlot('/1038259/ch-sem-mobilecube1', [[300, 250], [300, 600]], 'div-gpt-ad-ch-sem-mobilecube1').addService(googletag.pubads());
	googletag.pubads().enableSingleRequest();
	googletag.pubads().collapseEmptyDivs();
	googletag.enableServices();
	});</script>  <script type="text/javascript">var _sf_async_config = _sf_async_config || {};
    _sf_async_config.uid = 14529;
    _sf_async_config.domain = 'searchengineland.com';
    _sf_async_config.flickerControl = false;
    _sf_async_config.useCanonical = true;
    var _sf_startpt = (new Date()).getTime();</script> <script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>  <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	  })(window,document,'script','https://searchengineland.com/figz/wp-content/cache/busting/google-tracking/ga-4d88a66690f3506e6a2112b1c4dce0b4.js','ga');

	// Creates an adblock detection plugin.
	ga('provide', 'adblockTracker', function(tracker, opts) {
	  var ad = document.createElement('ins');
	  ad.className = 'AdSense';
	  ad.style.display = 'block';
	  ad.style.position = 'absolute';
	  ad.style.top = '-1px';
	  ad.style.height = '1px';
	  document.body.appendChild(ad);
	  tracker.set('dimension' + opts.dimensionIndex, !ad.clientHeight);
	  document.body.removeChild(ad);
	});

	ga('create', 'UA-86460999-1', 'auto', {'allowLinker': true, 'useAmpClientId': true});
	ga('set', 'dimension7', 'stopSpam');
	ga('set', 'anonymizeIp', true);
	ga('require', 'adblockTracker', {dimensionIndex: 6});
	ga('require', 'linker');
	ga('linker:autoLink', ['thirddoormedia.secure-platform.com'] );
	var dimensionValue = 'AMPDOC_HOST';
	ga('set', 'dimension7', dimensionValue);</script>  <script type="text/javascript">var _qevents = _qevents || [];
	  (function() {
	   var elem = document.createElement('script');
	   elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
	   elem.async = true;
	   elem.type = "text/javascript";
	   var scpt = document.getElementsByTagName('script')[0];
	   scpt.parentNode.insertBefore(elem, scpt);
	  })();</script>  <script>!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
		n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
		n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
		t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
		document,'script','https://searchengineland.com/figz/wp-content/cache/busting/facebook-tracking/fbpix-events-en_US-2.8.51.js');
		fbq('init', '423979991297359'); // Insert your pixel ID here.
		fbq('track', 'PageView');</script> <noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=423979991297359&ev=PageView&noscript=1"
/></noscript></head><body class="template-article" itemscope itemtype="http://schema.org/NewsArticle"><div id="div-gpt-ad-ch-sem-overlay" class="hidden-sm hidden-xs" style="height: 1px; width: 1px;"><script type="text/javascript">googletag.cmd.push(function() {googletag.display("div-gpt-ad-ch-sem-overlay"); });</script></div><div class="page-container main-outer-container"> <script type="text/javascript">var eventMethod = window.addEventListener ? "addEventListener" : "attachEvent";
		var eventer = window[eventMethod];
		var messageEvent = eventMethod == "attachEvent" ? "onmessage" : "message";

		eventer(messageEvent,function(e) {

		var key = e.message ? "message" : "data";
		 var data = e[key];

		var eventName = data.message || 'ignore';

		if (eventName == 'adContentAvailable') {
		 console.log( 'ad data available: ', data );

		 $('div,li').filter('[data-container-ad-unit-id="' + data.adUnit + '"]').html( data.content );
		 $('#img1').css('background-image', 'url(' + data.parallaxImg + ')');
		 $('body').addClass('parallax-active');
		 $('#floatingnav').addClass('stickyheader-mobile');

		 parallax.init();

		 }
		},false);</script> <div id='div-gpt-ad-1550690821057-0' style='height:1px; width:1px;'> <script>googletag.cmd.push(function() { googletag.display('div-gpt-ad-1550690821057-0'); });</script> </div> <script data-minify="1" src="https://searchengineland.com/figz/wp-content/cache/min/1/figz/wp-content/themes/searchengineland/js/parallax-9fe809ca3d0921c15e799b360c0bfe61.js" defer></script> <div class="parallax_img" id="img1" data-container-ad-unit-id="/1038259/SEL-Parallax" style="position:relative;"></div><header class="navbar navbar-default outer-header-container"><div class="container"><div id="floatingnav" class="navbar-header stickyheader stickyheader-mobile" style="background-color:#ffffff !important"> <button type="button" class="navbar-toggle"> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> </button><div itemscope itemtype="http://schema.org/Organization" class="header-reduced hidden-lg hidden-xs"><ul class="header-reduced-inner"><li class="brand"> <a itemprop="url" href="https://searchengineland.com" onClick="ga('send','event','internal','click','header logo');"> <img itemprop="logo" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/logo/SEL-block-white.svg" alt="Search Engine Land"><noscript><img src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/logo/SEL-block-white.svg" alt="Search Engine Land" /></noscript> </a></li><li class="sections"><a href="#">Sections</a><div class="submenu-wrap"><ul><li><a href="https://searchengineland.com/library/channel/seo" onClick="ga('send','event','navigation','read','channel seo');">SEO</a></li><li><a href="https://searchengineland.com/library/channel/sem" onClick="ga('send','event','navigation','read','channel sem');">SEM</a></li><li><a href="https://searchengineland.com/library/channel/mobile" onClick="ga('send','event','navigation','read','channel mobile');">Mobile</a></li><li><a href="https://searchengineland.com/library/channel/local" onClick="ga('send','event','navigation','read','channel local');">Local</a></li><li><a href="https://searchengineland.com/library/channel/retail" onClick="ga('send','event','navigation','read','channel retail');">Retail</a></li><li><a href="https://searchengineland.com/library/google" onClick="ga('send','event','navigation','read','category google');">Google</a></li><li><a href="https://searchengineland.com/library/bing" onClick="ga('send','event','navigation','read','category bing');">Bing</a></li><li><a href="https://searchengineland.com/guide/what-is-social-media-marketing" onClick="ga('send','event','navigation','read','channel social');">Social</a></li><li><a href="https://searchengineland.com" onClick="ga('send','event','navigation','read','home');">Home</a></li></ul></div></li><li> <a href="#"><span class="icomoon icon-search-01"></span></a><div class="drop"><div class="contain"><ul class="search"><li> <script type="text/javascript">function ajaxsearchsubmit(form){
    var search = encodeURIComponent(form.w.value);
    document.activeElement.blur();
    window.location="https://search.searchengineland.com/search?w=" +search;
    return false;
  }</script> <form class="navbar-form navbar-left" role="search" action="//search.searchengineland.com/search" method="GET" onsubmit="return ajaxsearchsubmit(this)"><div class="form-group"> <input type="hidden" name="asug"> <input type="text" class="form-control" placeholder="Search" name="w" value="" onfocus="this.value=''" id="sli_search_1" autocomplete="off"></div> <button type="submit" class="btn btn-default">Submit</button></form></li></ul></div></div></li><li><a href="#">Follow Us</a><span class="arrow"></span><div class="drop"><div class="contain"><ul class="social"><li class="icons"> <a class="rss" href="http://feeds.searchengineland.com/searchengineland" onClick="ga('send','event','social icon','connect','header rss');"><div class='sprite feeds_24x24'></div></a> <a class="email" href="https://searchengineland.com/newsletters" onClick="ga('send','event','signup','subscribe','header newsletter follow us');"><div class='sprite email-24x24'></div></a><a class="linkedin" href="https://www.linkedin.com/company/search-engine-land" onClick="ga('send','event','social icon','connect','header linkedin');"><div class='sprite linkedin_24x24'></div></a></li><li class="twitter"> <a href="https://twitter.com/sengineland" class="twitter-follow-button" data-show-count="true" data-lang="en" data-show-screen-name="false" onClick="ga('send', 'social', 'twitter', 'follow', 'https://searchengineland.com');">Follow</a></li><li class="facebook"> <iframe src="about:blank" data-rocket-lazyload="fitvidscompatible" data-lazy-src="//www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2Fsearchengineland&#038;width&#038;layout=button_count&#038;action=like&#038;show_faces=false&#038;share=false&#038;height=21"></iframe><noscript><iframe src="//www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2Fsearchengineland&amp;width&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;share=false&amp;height=21"></iframe></noscript></li></ul></div></div></li></ul></div><div class="header-full hidden-md hidden-sm"><div class="drop_shadow"></div><ul class="header-full-inner"><li class="mini-logo"> <a href="https://searchengineland.com" onClick="ga('send','event','internal','click','header logo');"> <img data-width="165" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/logo/SEL-block-white.svg" alt="Search Engine Land"><noscript><img data-width="165" src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/logo/SEL-block-white.svg" alt="Search Engine Land" /></noscript> </a></li><li data-channel-json="{&quot;id&quot;:&quot;seo&quot;,&quot;title&quot;:&quot;SEO&quot;,&quot;urlch&quot;:&quot;\/library\/channel\/seo&quot;,&quot;tracking&quot;:&quot;onClick=\&quot;ga('send','event','navigation','read','channel seo');\&quot;&quot;,&quot;sections&quot;:[&quot;&lt;a href=\&quot;\/library\/channel\/seo\&quot; onClick=\&quot;ga('send','event','navigation','read','channel seo');\&quot;&gt;All SEO&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/guide\/what-is-seo\&quot; onClick=\&quot;ga('send','event','navigation','read','what is seo');\&quot;&gt;What is SEO?&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/guide\/seo\&quot; onClick=\&quot;ga('send','event','navigation','read','how to seo');\&quot;&gt;How To Guides: SEO&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/google\/google-seo\&quot; onClick=\&quot;ga('send','event','navigation','read','google seo');\&quot;&gt;Google SEO&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/guide\/google-penalties\&quot; onClick=\&quot;ga('send','event','navigation','read','google penalties guide');\&quot;&gt;Google Penalties Guide&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/google\/google-algorithm-updates\&quot; onClick=\&quot;ga('send','event','navigation','read','google algorithm updates');\&quot;&gt;Google Algorithm Updates&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/google\/google-search-console\&quot; onClick=\&quot;ga('send','event','navigation','read','google search console');\&quot;&gt;Google Search Console&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/microsoft\/microsoft-bing-seo\&quot; onClick=\&quot;ga('send','event','navigation','read','bing seo');\&quot;&gt;Bing SEO&lt;\/a&gt;&quot;],&quot;features&quot;:[{&quot;title&quot;:&quot;Google News rolling out card layout on desktop search results&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2015\/11\/google-news-2015e-ss-1920-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/google-news-rolling-out-card-layout-on-desktop-search-results-319372\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail1 seo&#039;);\&quot;&quot;}, {&quot;title&quot;:&quot;Video: Lily Ray on recovering after a Google core update&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2019\/07\/lily-ray-barry-schwartz-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/video-lily-ray-on-recovering-after-a-google-core-update-319342\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail2 seo&#039;);\&quot;&quot;}, {&quot;title&quot;:&quot;Download the Guide to SEO&quot;,&quot;img&quot;:&quot;\/figz\/wp-content\/themes\/searchengineland\/img\/header\/sel-seo-periodic-250x250-v2.png&quot;,&quot;url&quot;:&quot;\/guide/seo\&quot; onClick=\&quot;ga('send','event','navigation','read','thumbnail3 seo');\&quot;&quot;}]}"><a href="/library/channel/seo" onClick="ga('send','event','navigation','read','channel seo');">SEO</a><span class="arrow"></span><div class="drop"><div class="contain"></div></div></li><li data-channel-json="{&quot;id&quot;:&quot;sem&quot;,&quot;title&quot;:&quot;SEM&quot;,&quot;urlch&quot;:&quot;\/library\/channel\/sem&quot;,&quot;tracking&quot;:&quot;onClick=\&quot;ga('send','event','navigation','read','channel sem');\&quot;&quot;,&quot;sections&quot;:[&quot;&lt;a href=\&quot;\/library\/channel\/sem\&quot; onClick=\&quot;ga('send','event','navigation','read','channel sem');\&quot;&gt;All SEM&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/guide\/what-is-paid-search\&quot; onClick=\&quot;ga('send','event','navigation','read','what is sem');\&quot;&gt;What is SEM?&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/guide\/ppc\&quot; onClick=\&quot;ga('send','event','navigation','read','ppc guide');\&quot;&gt;The Complete Guide To PPC&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/how-to\/how-to-sem\&quot; onClick=\&quot;ga('send','event','navigation','read','how to sem');\&quot;&gt;How To Guides: SEM&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/google\/google-adwords\&quot; onClick=\&quot;ga('send','event','navigation','read','google adwords');\&quot;&gt;Google Adwords&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/microsoft\/microsoft-bing-ads\&quot; onClick=\&quot;ga('send','event','navigation','read','bing ads');\&quot;&gt;Bing Ads&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/search-ads\&quot; onClick=\&quot;ga('send','event','navigation','read','search advertising');\&quot;&gt;More: Search Advertising&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/buyers-guides\/ppc-campaign-management-tools-a-buyers-guide\&quot; onClick=\&quot;ga('send','event','navigation','read','buyers guides ppc management tools dmd');\&quot;&gt;Buyers Guide: PPC Platforms&lt;\/a&gt;&quot;],&quot;features&quot;:[{&quot;title&quot;:&quot;Are your DSAs really outperforming standard ads? Find out with this ad copy length performance analysis script&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2019\/07\/Google-ads-script-2-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail1 sem&#039;);\&quot;&quot;}, {&quot;title&quot;:&quot;When to switch to standard delivery in Google Ads (hint: you should have switched yesterday)&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2019\/04\/google-ads-black-google-ads-shutterstock_1169319226-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/when-to-switch-to-standard-delivery-in-google-ads-hint-you-should-have-switched-yesterday-319332\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail2 sem&#039;);\&quot;&quot;},  {&quot;title&quot;:&quot;Actionable tactics. Networking. Trusted experts. Attend SMX East!&quot;,&quot;img&quot;:&quot;\/figz\/wp-content\/themes\/searchengineland\/img\/header\/smx-east-2019.jpg&quot;,&quot;url&quot;:&quot;https:\/\/marketinglandevents.com\/smx\/east\/?utm_source=sel&utm_medium=textlink&utm_campaign=smx+east+2019&utm_content=sem+navigation+tile\&quot; onClick=\&quot;ga('send','event','navigation','click','smx east 2019');\&quot;&quot;}]}"><a href="/library/channel/sem" onClick="ga('send','event','navigation','read','channel sem');">SEM</a><span class="arrow"></span><div class="drop"><div class="contain"></div></div></li><li data-channel-json="{&quot;id&quot;:&quot;mobile&quot;,&quot;title&quot;:&quot;Mobile&quot;,&quot;urlch&quot;:&quot;\/library\/channel\/mobile&quot;,&quot;tracking&quot;:&quot;onClick=\&quot;ga('send','event','navigation','read','channel mobile');\&quot;&quot;,&quot;sections&quot;:[&quot;&lt;a href=\&quot;\/library\/channel\/mobile\&quot; onClick=\&quot;ga('send','event','navigation','read','channel mobile');\&quot;&gt;All Mobile&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/google\/google-mobile\&quot; onClick=\&quot;ga('send','event','navigation','read','google mobile');\&quot;&gt;Google: Mobile Search&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/bing\/bing-mobile\&quot; onClick=\&quot;ga('send','event','navigation','read','bing mobile');\&quot;&gt;Bing: Mobile Search&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/mobile-marketing\&quot; onClick=\&quot;ga('send','event','navigation','read','mobile marketing');\&quot;&gt;Mobile Marketing&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/mobile-marketing\/app-indexing-deep-links\&quot; onClick=\&quot;ga('send','event','navigation','read','app indexing');\&quot;&gt;Mobile App Indexing&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/search-engine-optimization\/seo-mobile-search\&quot; onClick=\&quot;ga('send','event','navigation','read','mobile seo');\&quot;&gt;Mobile SEO&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/search-ads\/search-ads-mobile-search\&quot; onClick=\&quot;ga('send','event','navigation','read','mobile sem');\&quot;&gt;Mobile SEM&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;http:\/\/marketingland.com\/library\/channel\/mobile-marketing\&quot; onClick=\&quot;ga('send','event','navigation','read','marketingland');\&quot;&gt;Mobile at Marketing Land&lt;\/a&gt;&quot;],&quot;features&quot;:[{&quot;title&quot;:&quot;Google expands App campaigns search inventory on iOS browsers&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2017\/06\/apple-safari-icon-iphone-ss-1920-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/google-expands-app-campaigns-search-inventory-on-ios-browsers-319062\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail1 mobile&#039;);\&quot;&quot;}, {&quot;title&quot;:&quot;New app rating formula headed to Google Play will favor newer reviews&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2014\/07\/google-play-name-1920-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/new-app-rating-formula-headed-to-google-play-316697\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail2 mobile&#039;);\&quot;&quot;}, {&quot;title&quot;:&quot;Some cheers, a few sneers for Google\u2019s URL solution for AMP&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2019\/04\/AMPconfSignedExchanges-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/some-cheers-a-few-sneers-for-googles-url-solution-for-amp-315571\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail4 mobile&#039;);\&quot;&quot;}]}"><a href="/library/channel/mobile" onClick="ga('send','event','navigation','read','channel mobile');">Mobile</a><span class="arrow"></span><div class="drop"><div class="contain"></div></div></li><li data-channel-json="{&quot;id&quot;:&quot;local&quot;,&quot;title&quot;:&quot;Local&quot;,&quot;urlch&quot;:&quot;\/library\/channel\/local&quot;,&quot;tracking&quot;:&quot;onClick=\&quot;ga('send','event','navigation','read','channel local');\&quot;&quot;,&quot;sections&quot;:[&quot;&lt;a href=\&quot;\/library\/channel\/local\&quot; onClick=\&quot;ga('send','event','navigation','read','channel local');\&quot;&gt;All Local&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/google\/google-maps-local\&quot; onClick=\&quot;ga('send','event','navigation','read','google maps');\&quot;&gt;Google Maps &amp; Local Search&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/microsoft\/microsoft-bing-maps-local\&quot; onClick=\&quot;ga('send','event','navigation','read','bing maps');\&quot;&gt;Bing Maps &amp; Local Search&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/search-engines\/search-engines-maps-local-search-engines\&quot; onClick=\&quot;ga('send','event','navigation','read','local search engines');\&quot;&gt;Local Search Engines&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/how-to\/how-to-local-search-marketing\&quot; onClick=\&quot;ga('send','event','navigation','read','how to local search marketing');\&quot;&gt;How To Guides: Local Search&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/buyers-guides\/enterprise-local-marketing-automation-tools\&quot; onClick=\&quot;ga('send','event','navigation','read','buyers guide local automation 2014 dmd');\&quot;&gt;Buyers Guide: Local Automation&lt;\/a&gt;&quot;],&quot;features&quot;:[{&quot;title&quot;:&quot;What two big studies tell us about the state of local marketing&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2019\/02\/SterlingColumn2-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/what-two-big-studies-tell-us-about-the-state-of-local-marketing-319176\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail1 local&#039;);\&quot;&quot;}, {&quot;title&quot;:&quot;What do you do if Google My Business doesn\u2019t understand your business?&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2019\/06\/GMB_1920-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/what-do-you-do-if-google-my-business-doesnt-understand-your-business-318949\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail2 local&#039;);\&quot;&quot;}, {&quot;title&quot;:&quot;What\u2019s it like to be a Google Gold Product Expert?: An interview with Ben Fisher&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2019\/06\/benefits-of-gmb-gold-expert-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/whats-it-like-to-be-a-google-gold-product-expert-an-interview-with-ben-fisher-318281\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail3 local&#039;);\&quot;&quot;}]}"><a href="/library/channel/local" onClick="ga('send','event','navigation','read','channel local');">Local</a><span class="arrow"></span><div class="drop"><div class="contain"></div></div></li><li data-channel-json="{&quot;id&quot;:&quot;retail&quot;,&quot;title&quot;:&quot;Retail&quot;,&quot;urlch&quot;:&quot;\/library\/channel\/retail&quot;,&quot;tracking&quot;:&quot;onClick=\&quot;ga('send','event','navigation','read','channel retail');\&quot;&quot;,&quot;sections&quot;:[&quot;&lt;a href=\&quot;\/library\/channel\/retail\&quot; onClick=\&quot;ga('send','event','navigation','read','channel retail');\&quot;&gt;All Retail&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/google\/google-adwords\/google-adwords-product-listing-ads\&quot; onClick=\&quot;ga('send','event','navigation','read','google plas');\&quot;&gt;Google PLAs&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/search-ads\/search-ads-product-ads\&quot; onClick=\&quot;ga('send','event','navigation','read','product ads');\&quot;&gt;Product Ads&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/search-engines\/search-engines-shopping-search-engines\&quot; onClick=\&quot;ga('send','event','navigation','read','shopping search engines');\&quot;&gt;Shopping Search Engines&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;http:\/\/marketingland.com\/library\/channel\/retail-channel\&quot; onClick=\&quot;ga('send','event','navigation','read','marketingland channel retail');\&quot;&gt;Retail at Marketing Land&lt;\/a&gt;&quot;],&quot;features&quot;:[{&quot;title&quot;:&quot;New Google Shopping program enables customer photos to show with their product reviews&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2015\/11\/google-stars-reviews-rankings8-ss-1920-250x250.png&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/new-google-shopping-program-enables-customer-photos-to-show-with-their-product-reviews-319341\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail1 retail&#039;);\&quot;&quot;}, {&quot;title&quot;:&quot;Bullish forecast predicts 31 million Americans will &amp;#8216;shop&amp;#8217; on their smart speakers in 2019&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2019\/03\/amazon-alexa1-ss-1920-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/bullish-forecast-predicts-31-million-americans-will-shop-on-their-smart-speakers-in-2019-319262\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail2 retail&#039;);\&quot;&quot;}, {&quot;title&quot;:&quot;Pinterest broadens e-commerce capabilities with \u2018Complete the Look\u2019 visual search feature&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2019\/06\/pinterest-complete-the-look-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/pinterest-broadens-e-commerce-capabilities-with-complete-the-look-visual-search-feature-318309\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail3 retail&#039;);\&quot;&quot;} ]}"><a href="/library/channel/retail" onClick="ga('send','event','navigation','read','channel retail');">Retail</a><span class="arrow"></span><div class="drop"><div class="contain"></div></div></li><li data-channel-json="{&quot;id&quot;:&quot;google&quot;,&quot;title&quot;:&quot;Google&quot;,&quot;urlch&quot;:&quot;\/library\/google&quot;,&quot;tracking&quot;:&quot;onClick=\&quot;ga('send','event','navigation','read','category google');\&quot;&quot;,&quot;sections&quot;:[&quot;&lt;a href=\&quot;\/library\/google\&quot; onClick=\&quot;ga('send','event','navigation','read','category google');\&quot;&gt;All Google&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/google\/google-seo\&quot; onClick=\&quot;ga('send','event','navigation','read','google seo');\&quot;&gt;Google SEO&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/google\/google-algorithm-updates\&quot; onClick=\&quot;ga('send','event','navigation','read','google algorithm updates');\&quot;&gt;Google Algorithm Updates&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/google\/google-search-console\&quot; onClick=\&quot;ga('send','event','navigation','read','google search console');\&quot;&gt;Google Search Console&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/google\/google-adwords\&quot; onClick=\&quot;ga('send','event','navigation','read','google adwords');\&quot;&gt;Google Adwords&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/google\/google-adwords\/google-adwords-product-listing-ads\&quot; onClick=\&quot;ga('send','event','navigation','read','google plas');\&quot;&gt;Google Adwords: PLAS&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/google\/google-maps-local\&quot; onClick=\&quot;ga('send','event','navigation','read','google maps');\&quot;&gt;Google Maps &amp; Local Search&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/google\/google-mobile\&quot; onClick=\&quot;ga('send','event','navigation','read','google mobile');\&quot;&gt;Google Mobile Search&lt;\/a&gt;&quot;],&quot;features&quot;:[{&quot;title&quot;:&quot;Are your DSAs really outperforming standard ads? Find out with this ad copy length performance analysis script&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2019\/07\/Google-ads-script-2-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail1 google&#039;);\&quot;&quot;}, {&quot;title&quot;:&quot;Google shortnames and the case of the disappearing reviews&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2019\/06\/GMB_1920-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/google-shortnames-and-the-case-of-the-disappearing-reviews-319397\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail2 google&#039;);\&quot;&quot;}, {&quot;title&quot;:&quot;Alexa, Google Home now battling perception of being &amp;#8216;surveillance&amp;#8217; devices&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2019\/03\/google-home-hub2-pamela-parker-1920-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/google-home-alexa-now-battling-perception-of-being-surveillance-devices-319379\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail3 google&#039;);\&quot;&quot;}]}"><a href="/library/google" onClick="ga('send','event','navigation','read','category google');">Google</a><span class="arrow"></span><div class="drop"><div class="contain"></div></div></li><li data-channel-json="{&quot;id&quot;:&quot;bing&quot;,&quot;title&quot;:&quot;Bing&quot;,&quot;urlch&quot;:&quot;\/library\/bing&quot;,&quot;tracking&quot;:&quot;onClick=\&quot;ga('send','event','navigation','read','category bing');\&quot;&quot;,&quot;sections&quot;:[&quot;&lt;a href=\&quot;\/library\/bing\&quot; onClick=\&quot;ga('send','event','navigation','read','category bing');\&quot;&gt;All Bing&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/bing\/bing-seo\&quot; onClick=\&quot;ga('send','event','navigation','read','bing seo');\&quot;&gt;Bing SEO&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/bing\/bing-webmaster-tools\&quot; onClick=\&quot;ga('send','event','navigation','read','bing webmaster tools');\&quot;&gt;Bing Webmaster Tools&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/bing\/bing-ads\&quot; onClick=\&quot;ga('send','event','navigation','read','bing ads');\&quot;&gt;Bing Ads&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/bing\/bing-maps-local\&quot; onClick=\&quot;ga('send','event','navigation','read','bing maps');\&quot;&gt;Bing Maps &amp; Local Search&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/bing\/bing-mobile\&quot; onClick=\&quot;ga('send','event','navigation','read','bing mobile');\&quot;&gt;Bing Mobile&lt;\/a&gt;&quot;],&quot;features&quot;:[{&quot;title&quot;:&quot;Bing showing a streamlined recipe carousel in search results&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2015\/12\/bing-homepage-logo-ss-1920-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/bing-showing-a-streamlined-recipe-carousel-in-search-results-319356\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail1 bing&#039;);\&quot;&quot;}, {&quot;title&quot;:&quot;Ad customizers are now available in all Microsoft Advertising accounts&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2019\/07\/Microsoft_Ads_1920-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/ad-customizers-are-now-available-in-all-microsoft-advertising-accounts-319308\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail2 bing&#039;);\&quot;&quot;}, {&quot;title&quot;:&quot;What two big studies tell us about the state of local marketing&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2019\/02\/SterlingColumn2-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/what-two-big-studies-tell-us-about-the-state-of-local-marketing-319176\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail3 bing&#039;);\&quot;&quot;}]}"><a href="/library/bing" onClick="ga('send','event','navigation','read','category bing');">Bing</a><span class="arrow"></span><div class="drop"><div class="contain"></div></div></li><li data-channel-json="{&quot;id&quot;:&quot;social&quot;,&quot;title&quot;:&quot;Social&quot;,&quot;urlch&quot;:&quot;\/guide\/what-is-social-media-marketing&quot;,&quot;tracking&quot;:&quot;onClick=\&quot;ga('send','event','navigation','read','what is social media marketing');\&quot;&quot;,&quot;sections&quot;:[],&quot;features&quot;:[{&quot;title&quot;:&quot;Social Media News @ Marketing Land&quot;,&quot;img&quot;:&quot;\/figz\/wp-content\/themes\/searchengineland\/img\/header\/Social-Media-Icons-keyboard-ss-250.jpg&quot;,&quot;url&quot;:&quot;http:\/\/marketingland.com\/library\/channel\/social-media-marketing\&quot; onClick=\&quot;ga('send','event','navigation','read','marketingland channel social');\&quot;&quot;},{&quot;title&quot;:&quot; Buyer&#039;s Guide: Content Marketing Tools&quot;,&quot;img&quot;:&quot;\/figz\/wp-content\/themes\/searchengineland\/img\/header\/buyers-guide-content-marketing-250x250.jpg&quot;,&quot;url&quot;:&quot;\/buyers-guides\/content-marketing-tools\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;buyers guides content marketing tools dmd&#039;);\&quot;&quot;},{&quot;title&quot;:&quot;Buyers Guide: Social Media Management&quot;,&quot;img&quot;:&quot;\/figz\/wp-content\/themes\/searchengineland\/img\/header\/Marketers-Guide-to-Social-Media-Management-Platforms-250px.jpg&quot;,&quot;url&quot;:&quot;http:\/\/marketingland.com\/buyers-guides\/enterprise-social-media-management-software-a-buyers-guide\&quot; onClick=\&quot;ga('send','event','navigation','read','buyers guides enterprise social media software  dmd');\&quot;&quot;},{&quot;title&quot;:&quot;What Is Social Media Marketing?&quot;,&quot;img&quot;:&quot;\/figz\/wp-content\/themes\/searchengineland\/img\/header\/what-is-social-media-marketing-ss-250.jpg&quot;,&quot;url&quot;:&quot;\/guide\/what-is-social-media-marketing\&quot; onClick=\&quot;ga('send','event','navigation','read','what is social media marketing');\&quot;&quot;}]}"><a href="/guide/what-is-social-media-marketing" onClick="ga('send','event','navigation','read','channel social');">Social</a><span class="arrow"></span><div class="drop"><div class="contain"></div></div></li><li data-channel-json="{&quot;id&quot;:&quot;more&quot;,&quot;title&quot;:&quot;More&quot;,&quot;urlch&quot;:&quot;\/library&quot;,&quot;tracking&quot;:&quot;onClick=\&quot;ga('send','event','navigation','read','more');\&quot;&quot;,&quot;sections&quot;:[&quot;&lt;a href=\&quot;\/library\&quot; onClick=\&quot;ga('send','event','navigation','read','all topics');\&quot;&gt;All Topics&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/awards\&quot; onClick=\&quot;ga('send','event','navigation','read','awards');\&quot;&gt;Search Engine Land Awards&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/library\/channel\/industry\&quot; onClick=\&quot;ga('send','event','navigation','read','search industry');\&quot;&gt;Search Industry&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/newsletters\&quot; onClick=\&quot;ga('send','event','navigation','read','newsletters');\&quot;&gt;Newsletters&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/buyers-guides\&quot; onClick=\&quot;ga('send','event','navigation','read','buyers guides');\&quot;&gt;Buyers Guides&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;\/events\&quot; onClick=\&quot;ga('send','event','navigation','read','events');\&quot;&gt;Events&lt;\/a&gt;&quot;,&quot;&lt;a href=\&quot;http:\/\/marketingland.com\&quot; onClick=\&quot;ga('send','event','navigation','read','marketingland');\&quot;&gt;More at Marketing Land&lt;\/a&gt;&quot;],&quot;features&quot;:[{&quot;title&quot;:&quot;Here\u2019s your sneak peek at the SMX East agenda&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2017\/03\/smx-west-17-home-1980x1020-250x250.png&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/heres-your-sneak-peek-at-the-smx-east-agenda-319314\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail1 more&#039;);\&quot;&quot;}, {&quot;title&quot;:&quot;Only 30% of SMBs would recommend their current SEO provider, survey finds&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2017\/02\/client-meeting-567446380-ss-1920-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/only-30-of-smbs-would-recommend-their-current-seo-provider-survey-finds-319076\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail2 more&#039;);\&quot;&quot;}, {&quot;title&quot;:&quot;How to Build a Comprehensive Data Strategy&quot;,&quot;img&quot;:&quot;https:\/\/searchengineland.com\/figz\/wp-content\/seloads\/2018\/02\/Webinar-red-keyboard-ss-1920-250x250.jpg&quot;,&quot;url&quot;:&quot;https:\/\/searchengineland.com\/how-to-build-a-comprehensive-data-strategy-319008\&quot; onclick=\&quot;ga(&#039;send&#039;,&#039;event&#039;,&#039;navigation&#039;,&#039;read&#039;,&#039;thumbnail3 more&#039;);\&quot;&quot;}]}"><a onClick="ga('send','event','navigation','read','more');" href="/library/">More</a><span class="arrow"></span><div class="drop"><div class="contain"></div></div></li><li><a href="http://marketinglandevents.com/smx/?utm_source=sel&utm_medium=textlink&utm_campaign=smx&utm_content=navigation" onClick="ga('send','event','navigation','click','events');">Events</a></li><li></li><li></li><li> <a href="#"> <span class="icomoon icon-search-01"></span> </a><div class="drop"><div class="contain-small"><ul class="search"><li> <script type="text/javascript">// function ajaxsearchsubmit(form){
					//   var search = encodeURIComponent(form.w.value);
					//   document.activeElement.blur();
					//   window.location="https://search.searchengineland.com/search?w=" +search;
					//   return false;
					// }

					function noEmptySubmissions(form){

						var searchinput = encodeURIComponent(form.w.value);

						if (searchinput=="") {

							alert("The search query field cannot be empty. Please submit a query.");
							return false;

						} else {

							document.activeElement.blur(); 
							window.location = "http://search.searchengineland.com/search?w=" + search; 
							return false;

						}
					}</script> <form name="searchform" class="navbar-form navbar-left" role="search" action="//search.searchengineland.com/search" method="get" onsubmit="return noEmptySubmissions(this)"><div class="form-group"> <input type="hidden" name="asug"> <input type="text" class="form-control" placeholder="Search" name="w" value="" onfocus="this.value=''" id="sli_search_1" autocomplete="off"></div> <button type="submit" class="btn btn-default">Submit</button></form></li></ul></div></div></li><li class="pull-right"> <a href="#"><div class='sprite share-header'></div> </a><div class="drop"><div class="contain-small"><ul class="social"><li class="icons"> <a class="rss" href="http://feeds.searchengineland.com/searchengineland" onClick="ga('send','event','social icon','connect','header rss');"><div class='sprite feeds_24x24'></div></a> <a class="email" href="//searchengineland.com/newsletters" onClick="ga('send','event','signup','subscribe','header newsletter follow us');"><div class='sprite email-24x24'></div></a><a class="linkedin" href="https://www.linkedin.com/company/search-engine-land" onClick="ga('send','event','social icon','connect','header linkedin');"><div class='sprite linkedin_24x24'></div></a></li><li class="twitter"> <a href="https://twitter.com/sengineland" class="twitter-follow-button" data-show-count="true" data-lang="en" data-show-screen-name="false" onClick="ga('send', 'social', 'twitter', 'follow', 'https://searchengineland.com');">Follow</a></li><li class="facebook"> <iframe src="about:blank" data-rocket-lazyload="fitvidscompatible" data-lazy-src="//www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2Fsearchengineland&#038;width&#038;layout=button_count&#038;action=like&#038;show_faces=false&#038;share=false&#038;height=21"></iframe><noscript><iframe src="//www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2Fsearchengineland&amp;width&amp;layout=button_count&amp;action=like&amp;show_faces=false&amp;share=false&amp;height=21"></iframe></noscript></li></ul></div></div> </a></li><li class="pull-right"> <a href="https://www.twitter.com/sengineland"> <span class="icomoon icon-twitter-01"></span> </a></li><li class="pull-right"> <a href="http://www.facebook.com/searchengineland"> <span class="icomoon icon-facebook-01"></span> </a></li><li class="pull-right"> <a href="#"> SUBSCRIBE </a><div class="drop"><div class="contain-small"><ul class="search"><li><form id="nlh1" class="horizontal-form" action="/lib/process/process-newsletterv2.php" method="POST"><div class="form-group"><div class="col-md-9 mb2" style="padding-right:0px!important;margin-right:0px!important;margin-bottom:0px!important"><fieldset> <input type="hidden" name="formid" value="5691" /> <input type="hidden" name="formLocation" value="Header Hover Newsletter Form"> <input class="headerEmail form-control required" type="email" name="email" placeholder="Get our daily Search Engine Land newsletter."></fieldset></div> <button type="submit" name="submit" class="btn btn-primary headerButton" onClick="ga('send','event','signup','subscribe','header sel hover');">SUBSCRIBE</button></div></form></li></ul></div></div></li></ul></div></div><div class="header-top hidden-md hidden-sm hidden-lg"><div class="header-top-inner"><div class="branding hidden-xs"><h2><a href="https://searchengineland.com">Search Engine Land</a></h2></div><div class="branding hidden-lg hidden-mg hidden-sm"> <a href="https://searchengineland.com" onClick="ga('send','event','internal','click','header logo');"> <img class="phone-logo" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/logo/SEL-block.svg" alt="Search Engine Land"><noscript><img src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/logo/SEL-block.svg" alt="Search Engine Land" /></noscript> </a></div></div></div></div></header><div class="phone-nav-wrap container-fluid"><div class="row"><div class="hidden-lg hidden-md hidden-sm sidebar-offcanvas sidebar"><ul class="nav"><li><a href="https://searchengineland.com/library/channel/seo" onClick="ga('send','event','navigation','read','channel seo');">SEO</a></li><li><a href="https://searchengineland.com/library/channel/sem" onClick="ga('send','event','navigation','read','channel sem');">SEM</a></li><li><a href="https://searchengineland.com/library/channel/mobile" onClick="ga('send','event','navigation','read','channel mobile');">Mobile</a></li><li><a href="https://searchengineland.com/library/channel/local" onClick="ga('send','event','navigation','read','channel local');">Local</a></li><li><a href="https://searchengineland.com/library/channel/retail" onClick="ga('send','event','navigation','read','channel retail');">Retail</a></li><li><a href="https://searchengineland.com/library/google" onClick="ga('send','event','navigation','read','category google');">Google</a></li><li><a href="https://searchengineland.com/library/bing" onClick="ga('send','event','navigation','read','category bing');">Bing</a></li><li><a href="https://searchengineland.com/guide/what-is-social-media-marketing" onClick="ga('send','event','navigation','read','channel social');">Social</a></li><li><a href="https://searchengineland.com/newsletters" onClick="ga('send','event','navigation','read','newsletters');">Newsletters</a></li><li><a href="https://searchengineland.com" onClick="ga('send','event','navigation','read','home');">Home</a></li><li><div class="drop"><div class="contain"><ul class="search"><li><form class="navbar-form navbar-left" role="search" action="//search.searchengineland.com/search" method="GET" onsubmit="return ajaxsearchsubmit(this)"><div class="form-group"> <input type="hidden" name="asug"> <input type="text" class="form-control" placeholder="Search" name="w" value="" onfocus="this.value=''" id="sli_search_1" autocomplete="off"></div> <button type="submit" class="btn btn-default">Submit</button></form></li></ul></div></div></li></ul></div></div></div><div class="main-container-wrap"><div class="container-fluid"><div id="leaderboard"><div class="advertise-leaderboard advertise-728x90"><div id="div-gpt-ad-ch-sem-leaderboard" class="leaderboard-wide"><script type="text/javascript">googletag.cmd.push(function(){googletag.display("div-gpt-ad-ch-sem-leaderboard");});</script></div></div></div><div id="adSpacer"></div><div class="content full-width-header col-lg-12 col-md-12 col-sm-12"><article class="article-content"><div class="story-box sharing_controls_startpoint_fixed"><div class="channel"> <a href="/library/channel/sem">SEM</a></div><div class="hidden-xs hidden-sm"><div class="panel"><div class="panel-body" style="padding-bottom:0px!important;"><p>Sign up for our daily recaps of the ever-changing search marketing landscape.</p><form class="horizontal-form" id="nla" action="/lib/process/process-newsletterv2.php" method="POST"><div class="row"><div class="col-md-8 mb2" style="padding-right:0px!important;margin-right:0px!important;margin-bottom:0px!important"><fieldset> <input type="hidden" name="formid" value="5685" /> <input type="hidden" name="formLocation" value="Article Page Newsletter Form"><div class="control-group mb2"><div class="controls"> <input class="articleEmail form-control required" type="email" name="email" placeholder="Enter your email here."></div></div></fieldset></div><div class="col-md-4 mb2" style="padding-right:0px!important;margin-right:0px!important;margin-bottom:0px!important"> <button class="btn btn-primary articleButton" type="submit" name="submit" onClick="ga('send','event','signup','subscribe','article sel');"><span style="text-transform:none!important;">SUBSCRIBE</span></button></div></div></form><p style="font-size: 12px !important; color: gray !important;"><i>Note: By submitting this form, you agree to Third Door Media's <a style="color: #425E9B !important;" href="https://thirddoormedia.com/terms/">terms</a>. We respect your <a style="color: #425E9B !important;" href="https://thirddoormedia.com/privacy/">privacy</a>.</i></p></div></div></div> <br/><h1 itemprop="headline">Are your DSAs really outperforming standard ads? Find out with this ad copy length performance analysis script</h1><h2 class="subhead" itemprop="alternativeHeadline">Here's a script that pulls a report on ad performance based on copy length.</h2><div class="dateline"> <a href="https://searchengineland.com/author/daniel-gilbert" title="Posts by Daniel Gilbert" rel="author">Daniel Gilbert</a> on July 12, 2019 at 2:27 pm</div><div class="ad hidden-lg hidden-md hidden-sm" style="text-align: center; margin-bottom: 10px;"><div id="div-gpt-ad-ch-sem-mobilecube1"><script type="text/javascript">googletag.cmd.push(function() {googletag.display("div-gpt-ad-ch-sem-mobilecube1"); });</script></div></div><section
class="sharing_controls"
data-twitter-handle="@sengineland"
data-linkedin-source="Search Engine Land"
data-email-subject="A link from Search Engine Land"
data-email-body="Hi,[newline][newline]I've shared a link from Search Engine Land.[newline][newline][title]:[newline][shortlink][newline]"
data-permalink="https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416"
data-shortlink=""
data-featured-image="#insert-image-url"
data-full-title="Are your DSAs really outperforming standard ads? Find out with this ad copy length performance analysis script"
data-abbreviated-title="Are your DSAs really outperforming standard ads? Find out with this ad copy length performance analysis script"
data-sticky-startpoint-selector=".sharing_controls_startpoint_fixed"
data-sticky-endpoint-selector="footer"
data-content-startpoint-selector=".sharing_controls_startpoint_content"
data-content-endpoint-selector=".sharing_controls_endpoint_content"><ul><li data-id="twitter" class="twitter"><i class="icon-twitter-01" onclick="ga('send', 'social', 'twitter', 'share', 'https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416');"></i></li><li data-id="facebook" class="facebook"><i class="icon-facebook-01" onclick="ga('send', 'social', 'facebook', 'share', 'https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416');"></i></li><li data-id="linkedin" class="linkedin"><i class="icon-linkedin-01" onclick="ga('send', 'social', 'linkedin', 'share', 'https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416');"></i></li><li data-id="more" class="more"><span>More</span></li><li data-id="email" class="email after_more_button"><i class="icon-email-01" onclick="ga('send', 'social', 'email', 'share', 'https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416');"></i></li><li data-id="tumblr" class="tumblr after_more_button"><i class="icon-tumblr-01" onclick="ga('send', 'social', 'tumblr', 'share', 'https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416');"></i></li><li data-id="reddit" class="reddit after_more_button"><i class="icon-reddit-01" onclick="ga('send', 'social', 'reddit', 'share', 'https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416');"></i></li><li data-id="buffer" class="buffer after_more_button"><i class="icon-buffer-01" onclick="ga('send', 'social', 'buffer', 'share', 'https://searchengineland.com/are-your-dsas-really-outperforming-standard-ads-find-out-with-this-ad-copy-length-performance-analysis-script-319416');"></i></li></ul></section><div itemprop="articleBody" class="body-content"><div class="sharing_content_channel"><div class="sharing_controls_startpoint_content"></div></div><p>I&#8217;m sorry to say it, but the rumors are true: size matters. Well, ad copy length does, anyway.</p><p>Why else would Google keep increasing character limits? Their research found that the new expanded ads got 15% more clicks than other formats.</p><p>But are you actually making use of the space that&#8217;s available to you?</p><p>If you&#8217;ve never tested this before, it&#8217;s high time to assess your ad performance based on copy length.</p><p>With this script, you can do just that… and more! It can compare the performance of standard ads against Dynamic Search Ads (DSAs) across your account so you can check whether DSAs are actually working for you. As much as I love Google, you shouldn&#8217;t always trust them blindly – testing is key!</p><h2>What does the script do?</h2><p>This script allows you to see the performance of your ads over the last month aggregated by the number of characters used in each part of your ad copy: headlines, descriptions, and paths. So you get aggregated statistics for headline 1 with 30 characters, 29 characters, and so on.</p><p>It downloads a report of the account in a Google spreadsheet and creates a number of tabs: Headline 1, Headline 2, Headline 3, Description 1, Description 2, Description 3, Path 1, Path 2, and Path 3. It also creates three tabs (Headline, Description, and Path) where it concatenates all the respective components.</p><p>For each one of these components, the report shows the number of ads with a certain character count, and then the sum of those ads&#8217; clicks, impressions, cost, and conversions. It also shows an average cost per click, click-through-rate (CTR), and cost per acquisition (CPA).</p><p>In the headline tabs, DSAs are the ones shown having zero characters (though zeroes in descriptions and paths aren&#8217;t necessarily DSAs), so they&#8217;re easy to spot. By comparing them to the standard ads, you can check whether DSAs are really outperforming expanded text ads.</p><h2>Why does it matter?</h2><p>With more ad space, you can be more relevant to the search query and landing page. In other words, <a href="https://searchengineland.com/say-goodbye-to-low-quality-score-with-this-google-ads-script-301764">a better quality score</a> (and who wouldn&#8217;t want that?).</p><p>For example, if your CTR performance is underwhelming for two headlines with 30 characters, you might want to consider adding a third headline or using your word count more effectively.</p><p>If you spot paths only a few characters long, you&#8217;re probably missing out on valuable space. Longer paths look more natural to users, and improve relevance by telling users exactly what to expect from the landing page.</p><p>You can also verify what percentage of your spend is coming from small ad space, e.g. old accounts with old ad formats that haven&#8217;t been updated yet.</p><h2>How to get started</h2><p>The setup for this one is super easy. First, create a blank spreadsheet. Then, copy the script below and paste it in the scripts section of Google Ads. Replace <strong>YOUR_SPREADSHEET_URL_HERE</strong> at the top with your blank spreadsheet&#8217;s URL, and you&#8217;re ready to run it. Easy peasy.</p><p>You can also play around with changing the <a href="https://developers.google.com/google-ads/scripts/docs/reference/adsapp/adsapp_keywordselector#forDateRange_1">date range</a> and metrics if that works better for you. <a href="https://github.com/Brainlabs-Digital/Google-Ads-Scripts/blob/master/Analyzing/ad-copy-length-analysis.js" target="_blank" rel="noreferrer noopener" aria-label="Here's a link to the script. (opens in a new tab)">Here&#8217;s a link to the script.</a> Have fun!</p> <script src="https://gist.github.com/BrainlabsDigital/dbdb0646a7c27477badefa820a28f902.js"></script> <hr><p><em>Opinions expressed in this article are those of the guest author and not necessarily Search Engine Land. Staff authors are listed <a href="/staff">here</a>.</em></p><hr><div id="div-gpt-ad-ch-sem-articlemodule" class="hidden-sm hidden-xs hidden-md" style="margin-top: -10px !important;"><script type="text/javascript">googletag.cmd.push(function() {googletag.display("div-gpt-ad-ch-sem-articlemodule"); });</script></div> <br/><div class="about-author row"><h3>About The Author</h3><div class="information col-lg-12 col-md-12 col-sm-12"><div class="author-module"><div class="avatar"> <img class="img-responsive" src="data:image/svg+xml,%3Csvg%20xmlns='https://www.w3.org/2000/svg'%20viewBox='0%200%200%200'%3E%3C/svg%3E" data-lazy-src="/images/authors/DanielGilbert-lg.jpg"><noscript><img class="img-responsive" src="/images/authors/DanielGilbert-lg.jpg"></noscript></div><div class="about"><div class="name"> <strong><a href="https://searchengineland.com/author/daniel-gilbert" title="Posts by Daniel Gilbert" rel="author">Daniel Gilbert</a></strong></div><div class="twitter"> <iframe id="twitter-widget-0" src="about:blank" class="twitter-follow-button twitter-follow-button" title="Twitter Follow Button" data-twttr-rendered="true" style="width: 251px; height: 20px;" data-rocket-lazyload="fitvidscompatible" data-lazy-src="https://platform.twitter.com/widgets/follow_button.1392079123.html#_=1392650032615&#038;id=twitter-widget-0&#038;lang=en&#038;screen_name=dangilbertppc&#038;show_count=true&#038;show_screen_name=true&#038;size=m"></iframe><noscript><iframe id="twitter-widget-0" src="https://platform.twitter.com/widgets/follow_button.1392079123.html#_=1392650032615&amp;id=twitter-widget-0&amp;lang=en&amp;screen_name=dangilbertppc&amp;show_count=true&amp;show_screen_name=true&amp;size=m" class="twitter-follow-button twitter-follow-button" title="Twitter Follow Button" data-twttr-rendered="true" style="width: 251px; height: 20px;"></iframe></noscript></div> Daniel Gilbert is the CEO at <a target="_blank" rel="nofollow"  href="http://www.brainlabsdigital.com">Brainlabs</a>, the best paid media agency in the world (self-declared). He has started and invested in a number of big data and technology startups since leaving Google in 2010.</div></div></div></div><div class="related row hidden-xs"><div class="secondary topics col-lg-12 hidden-xs"><h3>Related Topics</h3> <a href="https://searchengineland.com/library/channel/sem">Channel: SEM</a><a href="https://searchengineland.com/library/google/google-adwords/adwords-scripts">Google: AdWords: AdWords Scripts</a><a href="https://searchengineland.com/library/columns/paid-search">Paid Search Column</a></div></div></div><div class="hidden-md hidden-lg"><div class="panel"><div class="panel-body" style="padding-bottom:0px!important;"><p>Sign up for our daily recaps of the ever-changing search marketing landscape.</p><form class="horizontal-form" id="nla" action="/lib/process/process-newsletterv2.php" method="POST"><div class="row"><div class="col-md-8 mb2" style="padding-right:0px!important;margin-right:0px!important;margin-bottom:0px!important"><fieldset> <input type="hidden" name="formid" value="5685" /> <input type="hidden" name="formLocation" value="Article Page Newsletter Form"><div class="control-group mb2"><div class="controls"> <input class="articleEmail form-control required" type="email" name="email" placeholder="Enter your email here."></div></div></fieldset></div><div class="col-md-4 mb2" style="padding-right:0px!important;margin-right:0px!important;margin-bottom:0px!important"> <button class="btn btn-primary articleButton" type="submit" name="submit" onClick="ga('send','event','signup','subscribe','article sel');"><span style="text-transform:none!important;">SUBSCRIBE</span></button></div></div></form><p style="font-size: 12px !important; color: gray !important;"><i>Note: By submitting this form, you agree to Third Door Media's <a style="color: #425E9B !important;" href="https://thirddoormedia.com/terms/">terms</a>. We respect your <a style="color: #425E9B !important;" href="https://thirddoormedia.com/privacy/">privacy</a>.</i></p></div></div></div> <br/><div><h3>We're listening.</h3><p>Have something to say about this article? Share it with us on <a href="https://www.facebook.com/searchengineland">Facebook</a>, <a href="https://twitter.com/sengineland">Twitter</a> or our <a href="https://www.linkedin.com/grp/home?gid=53266">LinkedIn Group</a>.</p></div></div> <script type="text/javascript">ga('send', 'pageview', {
								'dimension1': 'Channel: SEM',
								'dimension2': '',
								'dimension3': 'Daniel Gilbert',
								'dimension4': 'Paid Search Column',
								'dimension5': '2019-07-12 14:27:07'
							});</script> </article><aside class="right-rail"><div class="right-rail-content"><div class="ad hidden-xs"><div id="div-gpt-ad-ch-sem-sidebar"><script type="text/javascript">googletag.cmd.push(function() {googletag.display("div-gpt-ad-ch-sem-sidebar"); });</script></div></div><div class="events row mb2"><div><h3>Attend Our Conferences</h3><a target="_blank" onclick="ga('send','event','promo','click','sidebar smx');" href="https://marketinglandevents.com/smx/?utm_source=sel&utm_medium=textlink&utm_campaign=smx+home&utm_content=standunit+text"> <img class="img-responsive" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://marketingland.com/images/partners/smxlogo_270x130.png" alt="" /><noscript><img src="https://marketingland.com/images/partners/smxlogo_270x130.png" class="img-responsive" alt="" /></noscript> </a><p>Sept 30 - Oct 1: <a target="_blank" onclick="ga('send','event','promo','click','sidebar smx');" href="https://smxadvanced.eu?utm_source=ml&utm_medium=textlink&utm_campaign=smx+home&utm_content=standunit+text" style="text-decoration: underline;">SMX Advanced Europe</a></p><p>November 13-14: <a target="_blank" onclick="ga('send','event','promo','click','sidebar smx');" href="https://marketinglandevents.com/smx/east/?utm_source=sel&utm_medium=textlink&utm_campaign=smx+home&utm_content=standunit+text" style="text-decoration: underline;">SMX East</a></p><p>November 18-19: <a target="_blank" onclick="ga('send','event','promo','click','sidebar smx');" href="https://smxfrance.com/?utm_source=sel&utm_medium=textlink&utm_campaign=smx+home&utm_content=standunit+text" style="text-decoration: underline;">SMX Paris</a></p><p>February 18-20, 2020: <a target="_blank" onclick="ga('send','event','promo','click','sidebar smx');" href="http://marketinglandevents.com/smx/west/?utm_source=sel&utm_medium=textlink&utm_campaign=smx+home&utm_content=standunit+text" style="text-decoration: underline;">SMX West</a></p> <a id="smxModalOpen" onclick="ga('send','event','promo','click','sidebar martech conference video');"> <img class="img-responsive" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/placeholder/article/smx-vid-right-rail-650x255.png" alt="" /><noscript><img src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/placeholder/article/smx-vid-right-rail-650x255.png" class="img-responsive" alt="" /></noscript> </a><div id="smxModal" class="modal"><div class="modal-content" style="background-color:#1C57A4;"><div class="modal-header"> <span class="smxClose">&times;</span></div><div class="modal-body"><center> <iframe id="smxYouTubePlayer" width="480" height="270" src="" data-src="https://www.youtube.com/embed/tyEAcmeJ7FY" frameborder="0" allowfullscreen></iframe><h3 style="padding-top: 8px !important;color:#fff;"> <a href="https://marketinglandevents.com/smx/?utm_source=sel&utm_medium=standunit&utm_campaign=smx-video" target="_blank" style="color: #fff;" onclick="ga('send','event','video landing page','click','smx');">Attend SMX - Click Here</a></h3></center></div><div class="modal-footer"> <br></div></div></div> <a target="_blank" href="https://marketinglandevents.com/smx/?utm_source=sel&utm_medium=textlink&utm_campaign=smx+home&utm_content=standunit+button" class="btn btn-primary" role="button" onclick="ga('send','event','promo','click','sidebar smx');">Learn More About Our SMX Events</a><br><br><a target="_blank" onclick="ga('send','event','promo','click','sidebar martech');" href="https://www.martechconf.com/?utm_source=sel&utm_medium=textlink&utm_campaign=martech+home&utm_content=standunit+logo"> <img class="img-responsive" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://searchengineland.com/images/mtc-logo-2019.png" alt="" /><noscript><img src="https://searchengineland.com/images/mtc-logo-2019.png" class="img-responsive" alt="" /></noscript> </a><p>Gain new strategies and insights at the intersection of marketing, technology, and management. Our next conference will be held:</p><p>September 16-18, 2019: <a target="_blank" onclick="ga('send','event','promo','click','sidebar martech conference');" href="https://martechconf.com/east/?utm_source=sel&utm_medium=textlink&utm_campaign=mt+east+2018&utm_content=standunit" style="text-decoration: underline;">Boston</a></p> <a id="mtModalOpen" onclick="ga('send','event','promo','click','sidebar martech conference video');"> <img class="img-responsive" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/placeholder/article/video_mtc_650x320_v3.png" alt="" /><noscript><img src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/placeholder/article/video_mtc_650x320_v3.png" class="img-responsive" alt="" /></noscript> </a><div id="mtModal" class="modal"><div class="modal-content" style="background-color:#f1824e;"><div class="modal-header"> <span class="mtClose">&times;</span></div><div class="modal-body"><center> <div class="rll-youtube-player" data-id="NZPy7DufQ5E" data-query=""></div><noscript><iframe id="mtYouTubePlayer" width="480" height="270" src="//www.youtube.com/embed/NZPy7DufQ5E" frameborder="0" allowfullscreen></iframe></noscript><h3 style="margin-top: 8px !important;"> <a href="https://martechconf.com/?utm_source=sel&utm_medium=standunit&utm_campaign=martech-video" target="_blank" style="color: #fff;" onclick="ga('send','event','video landing page','click','martech');">Attend MarTech - Click Here</a></h3></center></div><div class="modal-footer"> <br></div></div></div></div><a target="_blank" href="https://martechconf.com/?utm_source=sel&utm_medium=textlink&utm_campaign=mt+home&utm_content=standunit+text" class="btn btn-primary" role="button" onclick="ga('send','event','promo','click','sidebar martech');">Learn More About Our MarTech Events</a></div><div class="dmd row"><div><h3>White Papers</h3><ul><li><a rel="nofollow" href="https://downloads.digitalmarketingdepot.com/BAZ_1907_BrndAuthen_landingpage.html?utm_source=sel&utm_medium=textlink&utm_campaign=whtiepapers" onclick="ga('send', 'event', 'promo', 'click', 'sidebar dmd whitepaper');">How to Build Brand Authenticity Using Customer Generated Content</a></li><li><a rel="nofollow" href="https://downloads.digitalmarketingdepot.com/SHA_1906_LdNurtTrnd_landingpage.html?utm_source=sel&utm_medium=textlink&utm_campaign=whtiepapers" onclick="ga('send', 'event', 'promo', 'click', 'sidebar dmd whitepaper');">Lead Nurturing Trends: Benchmarks from the Agency Perspective</a></li><li><a rel="nofollow" href="https://downloads.digitalmarketingdepot.com/PAN_1906_GdePerfLch_landingpage.html?utm_source=sel&utm_medium=textlink&utm_campaign=whtiepapers" onclick="ga('send', 'event', 'promo', 'click', 'sidebar dmd whitepaper');">A Marketer’s Guide to a Perfect Launch</a></li><li><a rel="nofollow" href="https://downloads.digitalmarketingdepot.com/ADT_1905_SearchGenZ_landingpage.html?utm_source=sel&utm_medium=textlink&utm_campaign=whtiepapers" onclick="ga('send', 'event', 'promo', 'click', 'sidebar dmd whitepaper');">The Future of Search: Capturing the Hearts and Minds of Generation Z</a></li><li><a rel="nofollow" href="https://downloads.digitalmarketingdepot.com/SHA_1906_Top10MstHv_landingpage.html?utm_source=sel&utm_medium=textlink&utm_campaign=whtiepapers" onclick="ga('send', 'event', 'promo', 'click', 'sidebar dmd whitepaper');">Top 10 Must-Haves for Marketing Automation</a></li></ul></div> <a target="_blank" href="http://digitalmarketingdepot.com/library/white-papers" class="btn btn-primary dmd-assets-btn" role="button" onclick="ga('send','event','promo','click','sidebar dmd whitepaper');">See More Whitepapers</a></div><div class="dmd row"><div><h3>Webinars</h3><ul><li><a rel="nofollow" href="https://event.on24.com/wcc/r/2043395/517510CDE7438ADCB24D830E484546ED?partnerref=dmdhome" title="Date of Webninar: 2019-07-25" onclick="ga('send', 'event', 'promo', 'click', 'sidebar dmd webcast');">B2B Site Search Best Practices: Giving Customers What They Need, When They Want it</a></li><li><a rel="nofollow" href="https://event.on24.com/wcc/r/2016243/36E429D802326F5278C0064CACAEA666" title="Date of Webninar: 2019-06-18" onclick="ga('send', 'event', 'promo', 'click', 'sidebar dmd webcast');">The Elements of SEO — Exploring The 2019 Periodic Table of SEO Factors</a></li><li><a rel="nofollow" href="https://event.on24.com/wcc/r/2022264/0048C474AB2D6600B687F91776258E16?partnerref=dmdhome" title="Date of Webninar: 2019-07-11" onclick="ga('send', 'event', 'promo', 'click', 'sidebar dmd webcast');">How to Build a Comprehensive Data Strategy</a></li></ul></div> <a target="_blank" href="http://digitalmarketingdepot.com/library/webinars" class="btn btn-primary dmd-assets-btn" role="button" onclick="ga('send','event','promo','click','sidebar dmd webinars');">See More Webinars</a></div><div class="dmd row"><div><h3>Research Reports</h3><ul><li><a rel="nofollow" href="https://downloads.digitalmarketingdepot.com/MIR_1902_IDResPlatf_landingpage_mtt.html?utm_source=sel&utm_medium=textlink&utm_campaign=sidebar" onclick="ga('send','event','promo','click','sidebar dmd research');">Identity Resolution Platforms</a></li><li><a rel="nofollow" href="https://downloads.digitalmarketingdepot.com/MIR_1808_CusDatPlat_landingpage_mtt.html?utm_source=sel&utm_medium=textlink&utm_campaign=sidebar" onClick="ga('send','event','promo','click','sidebar dmd research');">Customer Data Platforms</a></li><li><a rel="nofollow" href="https://downloads.digitalmarketingdepot.com/MIR_1602_B2BMrkgAuto_landingpage_mtt.html?utm_source=sel&utm_medium=textlink&utm_campaign=sidebar" onclick="ga('send','event','promo','click','sidebar dmd research');">B2B Marketing Automation Platforms</a></li><li><a rel="nofollow" href="https://downloads.digitalmarketingdepot.com/MIR_1512_SEOPlatfrm_landingpageMTT.html?utm_source=sel&utm_medium=textlink&utm_campaign=sidebar" onclick="ga('send','event','promo','click','sidebar dmd research');">Enterprise SEO Platforms</a></li><li><a rel="nofollow" href="https://downloads.digitalmarketingdepot.com/MIR_1510_CallAnlytc_landingpagebuyersguide.html?utm_source=sel&utm_medium=textlink&utm_campaign=sidebar" onclick="ga('send','event','promo','click','sidebar dmd research');">Call Analytics Platforms</a></li><li><a rel="nofollow" href="https://downloads.digitalmarketingdepot.com/MIR_1508_LocMkgAuto_landingpage_mtt.html?utm_source=sel&utm_medium=textlink&utm_campaign=sidebar" onclick="ga('send','event','promo','click','sidebar dmd research');">Local Marketing Automation Tools</a></li></ul></div> <a target="_blank" href="http://digitalmarketingdepot.com/library/research" class="btn btn-primary dmd-assets-btn" role="button" onclick="ga('send','event','promo','click','sidebar buyers guides');">See More Research</a></div><div class="e-solutions row"><div><h3>Search Engine Land’s Guide To SEO</h3> <a href="https://searchengineland.com/seotable?utm_source=sel&utm_medium=display&utm_campaign=seotable&utm_content=300x481-blue" onclick="ga('send','event','internal','read','sidebar seo periodic table');"><img src="data:image/svg+xml,%3Csvg%20xmlns='https://www.w3.org/2000/svg'%20viewBox='0%200%20300%20481'%3E%3C/svg%3E" alt="Master the Science of SEO" width="300" height="481" border="0" data-lazy-src="/images/seo-table-300x481-v2-blue.png"><noscript><img src="/images/seo-table-300x481-v2-blue.png" alt="Master the Science of SEO" width="300" height="481" border="0"></noscript></a></div></div></div></aside></div></div></div><footer class="site-footer"><div class="subscribe row"><div class="footer-inner"><div class="col-lg-3 col-md-3 col-sm-3 get"> Sign up for our NEW daily brief.</div><form id="nlf" class="horizontal-form" action="/lib/process/process-newsletterv2.php" method="POST"><div class="row"><div class="col-md-5 mb1" style="padding-right:0px!important;margin-right:0px!important;margin-bottom:0px!important"><fieldset> <input type="hidden" name="formid" value="5673" /> <input type="hidden" name="formLocation" value="Footer Newsletter Form"><div class="control-group mb2"><div class="controls"> <input class="footerEmail form-control required" type="email" name="email" placeholder="Get our daily Search Engine Land newsletter."></div></div></fieldset></div> <button class="btn btn-primary footerButton" type="submit" name="submit" onClick="ga('send','event','signup','subscribe','footer sel');">SUBSCRIBE</button></div></form></div></div><div class="gray row"><div class="footer-inner"><div class="col-lg-3 col-md-3 col-sm-4 col-xs-12"> <a class="logo" href="/" onclick="ga('send','event','internal','click','footer logo searchengineland');"> <img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/logo/SEL-logo.png" alt="Search Engine Land"><noscript><img src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/logo/SEL-logo.png" alt="Search Engine Land" /></noscript> </a><div class="row"><div class="col-lg-12 col-md-12 col-sm-12 col-xs-12"> <a class="pull-left" href="https://itunes.apple.com/us/app/search-engine-land/id1015557452?ls=1&mt=8" onclick="ga('send','event','promo','click','footer sel app');"> <img style="margin: 0px 0px 10px 14px;" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/icons/black-badge-appstore.png" alt="Download the Search Engine Land App on iTunes"><noscript><img src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/icons/black-badge-appstore.png" alt="Download the Search Engine Land App on iTunes" style="margin-left: 14px;"  /></noscript> </a> <a class="pull-left" href="https://play.google.com/store/apps/details?id=com.thirddoormedia.searchengineland" onclick="ga('send','event','promo','click','footer sel app');"> <img style="margin-left: 14px;" src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/icons/black-google-play-badge.png" alt="Download the Search Engine Land App on Google Play"><noscript><img src="https://searchengineland.com/figz/wp-content/themes/searchengineland/img/icons/black-google-play-badge.png" alt="Download the Search Engine Land App on Google Play" style="margin-left: 14px;"  /></noscript> </a></div></div></div><div class="col-lg-2 col-md-2 col-sm-2 col-xs-12"><h3>Channels</h3><ul><li><a href="https://searchengineland.com/library/channel/seo" onclick="ga('send','event','internal','click','footer channel seo');">SEO</a></li><li><a href="https://searchengineland.com/library/channel/sem" onclick="ga('send','event','internal','click','footer channel sem');">SEM</a></li><li><a href="https://searchengineland.com/library/channel/local" onclick="ga('send','event','internal','click','footer channel local');">Local</a></li><li><a href="https://searchengineland.com/library/channel/retail" onclick="ga('send','event','internal','click','footer channel retail');">Retail</a></li><li><a href="https://searchengineland.com/library/google" onclick="ga('send','event','internal','click','footer google');">Google</a></li><li><a href="https://searchengineland.com/library/bing" onclick="ga('send','event','internal','click','footer bing');">Bing</a></li><li><a href="https://searchengineland.com/guide/what-is-social-media-marketing" onClick="ga('send','event','internal','click','footer channel social');">Social</a></li></ul></div><div class="col-lg-2 col-md-2 col-sm-2 col-xs-12"><h3>Our Events</h3><ul><li><a href="https://marketinglandevents.com/smx/west/" onClick="ga('send','event','promo','click','footer smx west');">SMX West</a></li><li><a href="https://marketinglandevents.com/smx/london/" onClick="ga('send','event','promo','click','footer smx london');">SMX London</a></li><li><a href="https://marketinglandevents.com/smx/advanced/" onClick="ga('send','event','promo','click','footer smx advanced');">SMX Advanced</a></li><li><a href="http://marketinglandevents.com/smx/east/?utm_source=sel&utm_medium=textlink&utm_campaign=smx+home&utm_content=footer" onClick="ga('send','event','promo','click','footer smx east');">SMX East</a></li><li><a href="https://martechconf.com/west/" onClick="ga('send','event','promo','click','footer martech west');">MarTech West</a></li><li><a href="https://martechconf.com/east/" onClick="ga('send','event','promo','click','footer martech east');">MarTech East</a></li></ul></div><div class="col-lg-2 col-md-2 col-sm-2 col-xs-12"><h3>Resources</h3><ul><li><a href="https://digitalmarketingdepot.com/library/white-papers" onclick="ga('send','event','promo','click','footer whitepapers');">White Papers</a></li><li><a href="https://digitalmarketingdepot.com/library/research" onclick="ga('send','event','promo','click','footer research');">Research</a></li><li><a href="https://digitalmarketingdepot.com/library/webcasts" onclick="ga('send','event','promo','click','footer webinars');">Webinars</a></li><li><a href="https://searchmarketingexpo.com/" onclick="ga('send','event','promo','click','footer smx');">Search Marketing Expo</a></li><li><a href="https://martechconf.com/" onclick="ga('send','event','promo','click','footer martechconf');">MarTech Conference</a></li></ul></div><div class="col-lg-2 col-md-2 col-sm-2 col-xs-12"><h3>About</h3><ul><li><a href="https://searchengineland.com/about" onclick="ga('send','event','internal','click','footer about');">About Us</a></li><li><a href="https://searchengineland.com/contact" onclick="ga('send','event','internal','click','footer contact');">Contact</a></li><li><a href="https://searchengineland.com/privacypolicy" onclick="ga('send','event','internal','click','footer privacy');">Privacy</a></li><li><a href="https://thirddoormedia.com/marketing-solutions/" onclick="ga('send','event','internal','click','footer advertise');">Advertise</a></li><li><a href="https://thirddoormedia.com/marketing-solutions/" onclick="ga('send','event','promo','click','footer marketing services');">Marketing Services</a></li><li><a href="https://searchengineland.com/staff" onclick="ga('send','event','internal','click','footer staff');">Staff</a></li><li><a href="https://searchengineland.com/connect" onclick="ga('send','event','internal','click','footer connect');">Connect With Us</a></li></ul></div><div class="col-lg-1 col-md-1 col-sm-2 col-xs-12"><h3>Follow Us</h3><ul><li><span class="icon icon-facebook-01"></span><a href="https://www.facebook.com/searchengineland" rel="me" onClick="ga('send','event','social','connect','footer facebook');">Facebook</a></li><li><span class="icon icon-twitter-01"></span><a href="https://twitter.com/sengineland" onClick="ga('send','event','social','connect','footer twitter');">Twitter</a></li><li><span class="icon icon-linkedin-01"></span><a href="https://www.linkedin.com/company/search-engine-land" rel="me" onClick="ga('send','event','social','connect','footer linkedin');">LinkedIn</a></li><li><span class="icon icon-email-01"></span><a href="https://searchengineland.com/newsletters" onClick="ga('send','event','internal','click','footer newsletters');">Newsletters</a></li><li><span class="icon icon-instagram-01"></span><a href="https://instagram.com/searchengineland" onClick="ga('send','event','social','connect','footer instagram');">Instagram</a></li><li><span class="icon icon-rss-01"></span><a href="http://feeds.searchengineland.com/searchengineland" onClick="ga('send','event','social','connect','footer rss');">RSS</a></li><li><span class="icon icon-youtube-01"></span><a href="https://www.youtube.com/user/SearchEngineland" onClick="ga('send','event','social','connect','footer youtube');">Youtube</a></li><li><span class="icon icon-apple-01"></span><a href="https://itunes.apple.com/us/app/search-engine-land/id1015557452?ls=1&mt=8" onClick="ga('send','event','social','connect','footer sel app');">iOS App</a></li><li><span class="icon icon-android-01"></span><a href="https://play.google.com/store/apps/details?id=com.thirddoormedia.searchengineland" onClick="ga('send','event','social','connect','footer sel app');">Google Play</a></li></ul></div></div><div class="copyright"><p> &copy; 2019 Third Door Media, Inc. All rights reserved.</p></div></div></footer></div></div> <script type="text/javascript" defer="defer" src="https://searchengineland.com/js/ga_social_tracking.js"></script>  <script defer="defer" type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-53e918f660794f37"></script> <script type="text/javascript">var addthis_config = { data_ga_property: 'UA-944695-1', data_track_clickback: true, data_ga_social: true };</script> <script type="text/javascript">var addthis_share = {
	passthrough : {
			twitter: {
				via: "sengineland"
			}
		},
     url_transforms : {
          shorten: {
               twitter: 'bitly',
			   facebook: 'bitly',
			   linkedin: 'bitly',
			   google_plusone_share: 'bitly'
          }
     },
     shorteners : {
          bitly : {}
     }
}</script>  <script type="text/javascript" charset="utf-8">window.twttr = (function (d,s,id) {
     var t, js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) return; js=d.createElement(s); js.id=id;
     js.src="//platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs);
     return window.twttr || (t = { _e: [], ready: function(f){ t._e.push(f) } });
   }(document, "script", "twitter-wjs"));

   twttr.ready(function(twttr) {
       _ga.trackTwitter();
   });</script> <div id="fb-root"></div> <script>window.fbAsyncInit = function() {
      	FB.init({appId: '108479729193136', status: true, cookie: true, version: 'v2.8',
				 xfbml: true});
      _ga.trackFacebook();
    };

    // Load the SDK

(function(d, s, id){
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) {return;}
    js = d.createElement(s); js.id = id;
    js.src = "https://searchengineland.com/figz/wp-content/cache/busting/facebook-tracking/fbsdk-en_US.js";
    fjs.parentNode.insertBefore(js, fjs);
  }(document, 'script', 'facebook-jssdk'));</script>  <script type="text/javascript">(function() { var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true; po.src = 'https://apis.google.com/js/platform.js'; var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s); })();</script>  <script type="text/javascript">setTimeout(function(){var a=document.createElement("script");
var b=document.getElementsByTagName("script")[0];
a.src=document.location.protocol+"//dnn506yrbagrg.cloudfront.net/pages/scripts/0026/4062.js?"+Math.floor(new Date().getTime()/3600000);
a.async=true;a.type="text/javascript";b.parentNode.insertBefore(a,b)}, 1);</script>  <script type="text/javascript" charset="utf-8">var ju_num="828FA275-FF73-401E-AA39-40F5A6FAB6B1";var asset_host=(("https:"==document.location.protocol)?"https":"http")+'://d2j3qa5nc37287.cloudfront.net/';(function() {var s=document.createElement('script');s.type='text/javascript';s.async=true;s.src=asset_host+'coupon_code1.js';var x=document.getElementsByTagName('script')[0];x.parentNode.insertBefore(s,x);})();</script>  <script type="text/javascript">/* <![CDATA[ */ var google_conversion_id = 1041060991;
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true; /* ]]> */</script> <script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js"></script> <noscript><div style="display:inline;"> <img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/1041060991/?guid=ON&amp;script=0"/></div> </noscript> <script>(function(w,d,t,r,u){var f,n,i;w[u]=w[u]||[],f=function(){var o={ti:"5681447"};o.q=w[u],w[u]=new UET(o),w[u].push("pageLoad")},n=d.createElement(t),n.src=r,n.async=1,n.onload=n.onreadystatechange=function(){var s=this.readyState;s&&s!=="loaded"&&s!=="complete"||(f(),n.onload=n.onreadystatechange=null)},i=d.getElementsByTagName(t)[0],i.parentNode.insertBefore(n,i)})(window,document,"script","//bat.bing.com/bat.js","uetq");</script><noscript><img src="//bat.bing.com/action/0?ti=5681447&Ver=2" height="0" width="0" style="display:none; visibility: hidden;" /></noscript> <script type="text/javascript">$.ajax({
  url: '//munchkin.marketo.net/munchkin.js',
  dataType: 'script',
  cache: true,
  success: function() {
    Munchkin.init('727-ZQE-044');
  }
});</script> <script data-minify="1" type='text/javascript' defer="defer" src='https://searchengineland.com/figz/wp-content/cache/min/1/figz/wp-content/themes/searchengineland/js/script-7dcaea6c15310eb7a03fb55cbf88aef6.js'></script> <script data-minify="1" type='text/javascript' defer="defer" src='https://searchengineland.com/figz/wp-content/cache/min/1/figz/wp-content/themes/searchengineland/js/custom-c8caf9a6f94bee22f8457543b844135e.js'></script> <script>window.lazyLoadOptions = {
                elements_selector: "img[data-lazy-src],.rocket-lazyload,iframe[data-lazy-src]",
                data_src: "lazy-src",
                data_srcset: "lazy-srcset",
                data_sizes: "lazy-sizes",
                class_loading: "lazyloading",
                class_loaded: "lazyloaded",
                threshold: 100,
                callback_loaded: function(element) {
                    if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
                        if (element.classList.contains("lazyloaded") ) {
                            if (typeof window.jQuery != "undefined") {
                                if (jQuery.fn.fitVids) {
                                    jQuery(element).parent().fitVids();
                                }
                            }
                        }
                    }
                }};
        window.addEventListener('LazyLoad::Initialized', function (e) {
            var lazyLoadInstance = e.detail.instance;
        
            if (window.MutationObserver) {
                var observer = new MutationObserver(function(mutations) {
                    var image_count = 0;
                    var iframe_count = 0;
                    var rocketlazy_count = 0;

                    mutations.forEach(function(mutation) {
                        for (i = 0; i < mutation.addedNodes.length; i++) {
                            if (typeof mutation.addedNodes[i].getElementsByTagName !== 'function') {
                                return;
                            }

                           if (typeof mutation.addedNodes[i].getElementsByClassName !== 'function') {
                                return;
                            }

                            images = mutation.addedNodes[i].getElementsByTagName('img');
                            is_image = mutation.addedNodes[i].tagName == "IMG";
                            iframes = mutation.addedNodes[i].getElementsByTagName('iframe');
                            is_iframe = mutation.addedNodes[i].tagName == "IFRAME";
                            rocket_lazy = mutation.addedNodes[i].getElementsByClassName('rocket-lazyload');

                            image_count += images.length;
			                iframe_count += iframes.length;
			                rocketlazy_count += rocket_lazy.length;
                            
                            if(is_image){
                                image_count += 1;
                            }

                            if(is_iframe){
                                iframe_count += 1;
                            }
                        }
                    } );

                    if(image_count > 0 || iframe_count > 0 || rocketlazy_count > 0){
                        lazyLoadInstance.update();
                    }
                } );
                
                var b      = document.getElementsByTagName("body")[0];
                var config = { childList: true, subtree: true };
                
                observer.observe(b, config);
            }
        }, false);</script><script data-no-minify="1" async src="https://searchengineland.com/figz/wp-content/plugins/wp-rocket/assets/js/lazyload/11.0.6/lazyload.min.js"></script><script>function lazyLoadThumb(e){var t='<img data-lazy-src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"><noscript><img src="https://i.ytimg.com/vi/ID/hqdefault.jpg" alt="" width="480" height="360"></noscript>',a='<div class="play"></div>';return t.replace("ID",e)+a}function lazyLoadYoutubeIframe(){var e=document.createElement("iframe"),t="https://www.youtube.com/embed/ID?autoplay=1";t+=0===this.dataset.query.length?'':'&'+this.dataset.query;e.setAttribute("src",t.replace("ID",this.dataset.id)),e.setAttribute("frameborder","0"),e.setAttribute("allowfullscreen","1"),this.parentNode.replaceChild(e,this)}document.addEventListener("DOMContentLoaded",function(){var e,t,a=document.getElementsByClassName("rll-youtube-player");for(t=0;t<a.length;t++)e=document.createElement("div"),e.setAttribute("data-id",a[t].dataset.id),e.setAttribute("data-query", a[t].dataset.query),e.innerHTML=lazyLoadThumb(a[t].dataset.id),e.onclick=lazyLoadYoutubeIframe,a[t].appendChild(e)});</script>  <script data-minify="1" type="text/javascript" defer="defer" src="https://searchengineland.com/figz/wp-content/cache/min/1/figz/wp-content/themes/searchengineland/js/modules/sharing_controls-0b72f82a2ad53e38b5fc540c3313416e.js"></script> <div class="center"><h5 class="bg-success" id="adb-not-enabled" style="display: none;"></h5><h5 class="bg-danger" id="adb-enabled" style="display: none;"></h5></div> <script data-minify="1" src="https://searchengineland.com/figz/wp-content/cache/min/1/figz/wp-content/themes/searchengineland/js/modules/checkdetection-6ead9b5a007060a20cab8970cc7173a9.js"></script> <script>// Configure the adblock detector
	(function(){
		var enabledEl = document.getElementById('adb-enabled');
		var disabledEl = document.getElementById('adb-not-enabled');
		function adBlockDetected() {
			enabledEl.style.display = 'block';
			disabledEl.style.display = 'none';
		}
		function adBlockNotDetected() {
			disabledEl.style.display = 'block';
			enabledEl.style.display = 'none';
		}

		if(typeof window.adblockDetector === 'undefined') {
			adBlockDetected();
		} else {
			window.adblockDetector.init(
				{
					debug: true,
					found: function(){
						adBlockDetected();
						//console.log('Adblock detected');
					},
					notFound: function(){
						adBlockNotDetected();
						//console.log('Adblock not detected');
					}
				}
			);
		}
	}());</script> <script data-minify="1" src="https://searchengineland.com/figz/wp-content/cache/min/1/figz/wp-content/themes/searchengineland/js/modules/collapse-c35827d95a71ba2e5848b3db2692c4b8.js" defer></script> <script data-minify="1" src="https://searchengineland.com/figz/wp-content/cache/min/1/figz/wp-content/themes/searchengineland/js/modules/transition-c2a6b90cbd6f9ca90b70d6b49fd810b3.js" defer></script> <noscript><link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Oswald%3A300%2C400%2C700%7CRoboto%3A300%2C400%2C700&display=swap" /></noscript><noscript><link rel="stylesheet" href="https://searchengineland.com/figz/wp-content/cache/min/1/15687c107e76059dfb406da3f7e2d7ab.css" data-minify="1" /></noscript></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1562956542 -->